Hamid Fadishei's Blog

September 12, 2010

Joomla! Error: the XML response that was returned from the server is invalid

Filed under: CMS,Joomla!,PHP — fadishei @ 5:36 pm

Many people get this error while they try to install Joomla! content management system. The interesting fact is that the top-in-Google forum thread about this problem, while not addressing the underlying cause properly, is locked and no further replies is possible there. Thus I will share my personal experience in this regard here.

This problem emerges when Joomla! installer can not process the XML response from the server. Many times this occurs when the response is cluttered with warning and notice messages generated by PHP. Therfore my advice is to first revisit your php.ini if you face this error message and make sure that you have the proper settings there. For me, the problem was gone as soon as I changed this line:

error_reporting = E_ALL

to this:

error_reporting = E_ALL & ~E_NOTICE
Advertisements

6 Comments »

  1. یه دنیا ممنون بابت راهنمایی خوبتون

    Comment by mahbubeh — October 15, 2010 @ 5:07 am | Reply

    • خواهش می کنم. خوشحالم که مفید بود

      Comment by fadishei — October 15, 2011 @ 6:06 am | Reply

  2. It does not worked for me.

    Comment by JB — February 13, 2011 @ 5:06 am | Reply

  3. Hello I’m Jacck, from Colombia, I too try to install Joomla and get this error!.

    I continued whit the installation and see that joomla say, your browser don’t have activate the cookies, and joomla can’t continue, inmediatly I was to mozilla firefox and here I install the example data perfectly.

    Comment by jacckjacck1 — February 23, 2011 @ 3:42 am | Reply

    • For enabling cookies, you should edit your browser preferences. Although the exact procedure varies on different browsers, it should not be difficult to find by googling.

      Comment by fadishei — February 25, 2011 @ 9:53 am | Reply

  4. this did not help, although i remember a few times it did… installing the sample sql manually (example through phpmyadmin) worked. thanks! nice blog!

    Comment by Jerome Esperanza — December 29, 2011 @ 2:07 am | Reply


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Create a free website or blog at WordPress.com.

%d bloggers like this: